Version 4.0 is out – OCT 27 2018 – Check the changelog.

WooCommerce 3.5.x compatible

WordPress 4.9.x compatible

General Features

GDPR compliant
Absolutely no programming skills required
Creative modern minimalistic design
Reliable support
Detailed printable documentation
Video tutorials (available on YouTube)
Drag and drop page builder
Highly customizable
Built with lat

Compatible with Below Plugins:

  • bbPress 2.5.x
  • Gravity Forms
  • Visual Composer 5.1.x
  • WooCommerce 3.4.x
  • WooCommerce 3.3.x
  • WooCommerce 3.2.x
  • WooCommerce 3.1.x
  • WooCommerce 3.0.x
  • WPML

Compatible with Below Browsers:

  • IE10
  • IE11
  • Firefox
  • Safari
  • Opera
  • Chrome
  • Edge